mirror of
https://github.com/motioneye-project/motioneyeos.git
synced 2025-04-23 06:47:16 +00:00
33 lines
810 B
Makefile
33 lines
810 B
Makefile
################################################################################
|
|
#
|
|
# neard
|
|
#
|
|
################################################################################
|
|
|
|
NEARD_VERSION = 0.16
|
|
NEARD_SOURCE = neard-$(NEARD_VERSION).tar.xz
|
|
NEARD_SITE = $(BR2_KERNEL_MIRROR)/linux/network/nfc
|
|
NEARD_LICENSE = GPL-2.0
|
|
NEARD_LICENSE_FILES = COPYING
|
|
|
|
NEARD_DEPENDENCIES = host-pkgconf dbus libglib2 libnl
|
|
NEARD_CONF_OPTS = --disable-traces
|
|
|
|
ifeq ($(BR2_PACKAGE_NEARD_TOOLS),y)
|
|
NEARD_CONF_OPTS += --enable-tools
|
|
endif
|
|
|
|
ifeq ($(BR2_INIT_SYSTEMD),y)
|
|
NEARD_CONF_OPTS += --enable-systemd
|
|
NEARD_DEPENDENCIES += systemd
|
|
else
|
|
NEARD_CONF_OPTS += --disable-systemd
|
|
endif
|
|
|
|
define NEARD_INSTALL_INIT_SYSV
|
|
$(INSTALL) -D -m 0755 package/neard/S53neard \
|
|
$(TARGET_DIR)/etc/init.d/S53neard
|
|
endef
|
|
|
|
$(eval $(autotools-package))
|