mirror of
https://github.com/motioneye-project/motioneyeos.git
synced 2025-04-24 15:27:16 +00:00
23 lines
749 B
Makefile
23 lines
749 B
Makefile
################################################################################
|
|
#
|
|
# clapack
|
|
#
|
|
################################################################################
|
|
|
|
CLAPACK_VERSION = 3.2.1
|
|
CLAPACK_SOURCE = clapack-$(CLAPACK_VERSION)-CMAKE.tgz
|
|
# This package provides 3 libraries:
|
|
# - libf2c.a (not installed)
|
|
# - libblas (statically linked with libf2c.a)
|
|
# - liblapack (statically linked with libf2c.a)
|
|
CLAPACK_LICENSE = HPND (libf2c), BSD-3-Clause (libblas and liblapack)
|
|
CLAPACK_LICENSE_FILES = F2CLIBS/libf2c/Notice COPYING
|
|
CLAPACK_SITE = http://www.netlib.org/clapack
|
|
CLAPACK_INSTALL_STAGING = YES
|
|
|
|
ifneq ($(BR2_PACKAGE_CLAPACK_ARITH_H),)
|
|
CLAPACK_CONF_OPTS += -DARITH_H=$(BR2_PACKAGE_CLAPACK_ARITH_H)
|
|
endif
|
|
|
|
$(eval $(cmake-package))
|