mirror of
https://github.com/motioneye-project/motioneyeos.git
synced 2025-04-23 23:07:16 +00:00

The license heading in source files includes the "or any later" language. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com> (cherry picked from commit cfa3447a7829aed59ce673b22212f5c82f83fc61) Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
27 lines
785 B
Makefile
27 lines
785 B
Makefile
################################################################################
|
|
#
|
|
# psmisc
|
|
#
|
|
################################################################################
|
|
|
|
PSMISC_VERSION = 23.1
|
|
PSMISC_SITE = http://downloads.sourceforge.net/project/psmisc/psmisc
|
|
PSMISC_SOURCE = psmisc-$(PSMISC_VERSION).tar.xz
|
|
PSMISC_LICENSE = GPL-2.0+
|
|
PSMISC_LICENSE_FILES = COPYING
|
|
PSMISC_DEPENDENCIES = ncurses $(TARGET_NLS_DEPENDENCIES)
|
|
# Patching Makefile.am
|
|
PSMISC_AUTORECONF = YES
|
|
|
|
define PSMISC_GIT_VERSION_EXEC
|
|
chmod +x $(@D)/misc/git-version-gen
|
|
endef
|
|
PSMISC_POST_PATCH_HOOKS += PSMISC_GIT_VERSION_EXEC
|
|
|
|
ifeq ($(BR2_TOOLCHAIN_HAS_SSP),)
|
|
# Don't force -fstack-protector when SSP is not available in toolchain
|
|
PSMISC_CONF_OPTS = --disable-harden-flags
|
|
endif
|
|
|
|
$(eval $(autotools-package))
|