mirror of
https://github.com/motioneye-project/motioneyeos.git
synced 2025-04-21 13:57:16 +00:00

Drop ED_CONF_OPTS; unused since commit 2a37b625e2 ("ed: Convert to generic package infrastructure"). Add license file hash. Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
30 lines
636 B
Makefile
30 lines
636 B
Makefile
################################################################################
|
|
#
|
|
# ed
|
|
#
|
|
################################################################################
|
|
|
|
ED_VERSION = 1.15
|
|
ED_SITE = $(BR2_GNU_MIRROR)/ed
|
|
ED_SOURCE = ed-$(ED_VERSION).tar.lz
|
|
ED_LICENSE = GPL-3.0+
|
|
ED_LICENSE_FILES = COPYING
|
|
|
|
define ED_CONFIGURE_CMDS
|
|
(cd $(@D); \
|
|
$(TARGET_MAKE_ENV) ./configure \
|
|
--prefix=/usr \
|
|
$(TARGET_CONFIGURE_OPTS) \
|
|
)
|
|
endef
|
|
|
|
define ED_BUILD_CMDS
|
|
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
|
|
endef
|
|
|
|
define ED_INSTALL_TARGET_CMDS
|
|
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" install
|
|
endef
|
|
|
|
$(eval $(generic-package))
|