mirror of
https://github.com/motioneye-project/motioneyeos.git
synced 2025-04-22 22:37:17 +00:00

Commit 54eeb08d6498e54cc77e212e4f9873b579f76638 wrongly replaced `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs` by "$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs" Fixes: - http://autobuild.buildroot.org/results/3dd8c768beef075494d6be7eff4cbb57b5ec8a41 Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
35 lines
895 B
Makefile
35 lines
895 B
Makefile
################################################################################
|
|
#
|
|
# ngrep
|
|
#
|
|
################################################################################
|
|
|
|
NGREP_VERSION = 1_47
|
|
NGREP_SITE = $(call github,jpr5,ngrep,V$(NGREP_VERSION))
|
|
NGREP_LICENSE = BSD-4-Clause-like, BSD-3-Clause (tcpkill)
|
|
NGREP_LICENSE_FILES = LICENSE
|
|
NGREP_INSTALL_STAGING = YES
|
|
# We're patching configure.in
|
|
NGREP_AUTORECONF = YES
|
|
|
|
ifeq ($(BR2_STATIC_LIBS),y)
|
|
NGREP_CONF_ENV += LIBS=`$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`
|
|
endif
|
|
|
|
NGREP_CONF_OPTS = \
|
|
--with-pcap-includes=$(STAGING_DIR)/usr/include/pcap \
|
|
--enable-pcre \
|
|
--disable-dropprivs \
|
|
--disable-pcap-restart
|
|
|
|
NGREP_DEPENDENCIES = libpcap pcre
|
|
|
|
ifeq ($(BR2_PACKAGE_LIBNET),y)
|
|
NGREP_DEPENDENCIES += libnet
|
|
NGREP_CONF_OPTS += --enable-tcpkill
|
|
else
|
|
NGREP_CONF_OPTS += --disable-tcpkill
|
|
endif
|
|
|
|
$(eval $(autotools-package))
|